Tsunami Development

Fareen Elias February 05, 2013 5 Announcements

Release of Tsunami A2013

Overview

We are pleased to announce the release of Tsunami A2013.  The newest release fixes modest bugs in the code as well as introduces new performance features. Overall, these new features will give the user increased control over run times and better imaging with improved stability.

PSTM 6.3                                                                                                     A2013 version

 

Added New Port Connectivity Parameter: mnport

Building off of Tsunami B2012, which improved port connectivity by searching for unused ports, you can assign a starting port number by adding mnport= {port number} to your parameter file. PSTM will start looking for and connecting to ports greater than this port number. This is especially helpful if users are running multiple jobs on the same cluster simultaneously. This feature is not currently available on the GUI and must be added manually to the parameter file.

 

Added Performance Log Detail Parameter: prntprf

For additional convenience, we have added a parameter that displays detailed information about the job’s transfer rate, prntprf={n}, where  the value {n} will print the data transfer rate every nth megabyte. This feature is not currently available on the GUI and must be added manually to the parameter file. The print performance parameter will do two things:

  1. The job’s log file found in the project directory will note the transfer rate
  2. The temporary log file held on the /tmp directory of the computer node will print the number of traces processed and the transfer rate. This file is automatically deleted when the job completes.  

 

Tsunami recommends a value of prntprf= 1000 for Kirchoff Migrations.

 

Offset Increment Test

If outputting gathers in previous versions of PSTM, an offset increment was not required and the job would crash with a non-descript error message. A2013 requires an offset increment (incoffo= ) if the number of offsets (numoffo= ) is greater than 1.

 

Improved Trace Weight Calculations

Trace weights are now calculated proportional to the area of live CDPs for an offset, instead of the area of all CDPs for an offset.  This reduces run time and improves accuracy of trace weights.

 

Adjusted HTI computation

A2013 has undergone testing to ensure accuracy of output when using HTI.

 

Bug Fixes:

  • For 2D crooked lines, the output was off by one trace. This is now solved.
  • Fixed bug that hung jobs after last checkpoint
  • Increased performance of time/frequency pairs introduced by bug; millions of shifts/sums were at ~90, currently at 140
  • Using the bandpass filter parameters no longer introduces false events in deep sections
  • Corrected rounding down error of output samples    
  • Fixed false error message for building a trace database without floating datum; an error message concerning incorrect floating datum parameters was printed to the log file, even if not using floating datum.
  • Fixed outputting of an extra CDP

 

 

 

PSDM 6.3                                                                                                       A2013 version

 

Added Performance Log Detail Parameter: prntprf

For additional convenience, we have added a parameter that displays detailed information about the job’s transfer rate, prntprf={n}, where  the value {n} will print the data transfer rate every nth megabyte. This feature is not currently available on the GUI and must be added manually to the parameter file. Print performance will do two things:

  1. The job’s log file found in the project directory will note the transfer rate
  2. The temporary log file held on the /tmp directory of the computer node will print the number of traces processed and the transfer rate. This file is automatically deleted when the job completes.   

 

Tsunami recommends a value of prntprf= 1000 for Kirchoff Migrations.

 

Enhanced Travel Time Interpolator

The travel time interpolator was changed to a smoother interpolation function and now uses the nearest four shots per source/receiver instead of the nearest three.

 

Offset Increment Test

If outputting gathers in previous versions of PSTM, an offset increment was not required and the job used to crash with a non-descriptive error message. A2013 requires an offset increment (incoffo= ) if the number of offsets (numoffo= ) is greater than 1.

 

Bug Fixes:

  • The application will now ignore signal 15 errors, which used to kill some batch queue jobs after a certain period of time
  • Fixed a bug which did not output the correct CDP and sample rate header values
  • Using the bandpass filter parameters no longer introduces false events in deep sections
  • The program no longer uses all of the disk cache on selected compute nodes when specified otherwise


Rays 6.0                                                                                                         A2013 version                                        

Added Performance Log Detail Parameter: prntprf

For additional convenience, we have added a parameter that displays detailed information about the job’s transfer rate, prntprf={n}, where  the value {n} will print the data transfer rate every nth megabyte. This feature is not currently available on the GUI and must be added manually to the parameter file.  This will do two things:

  1. The job’s log file found in the project directory will note the transfer rate
  2. The temporary log file held on the /tmp directory of the computer node will print the number of traces processed and the transfer rate. This file is automatically deleted when the job completes. 

 

New Input Method for TTI Anisotropy

In addition to supplying a dip and azimuth file for anisotropy migrations, users can now use inline and xline dip files, allowing more flexibility for the processor. To use this option, go to the Input tab and click on the radio button for “Use Inline Dip/ Xline Dip”.

 

Bug Fixes:

  • Fixed velocity model output was off by half a grid
  • Fixed incorrect replacement velocity if using a floating datum above a flat datum
  • Improved accuracy of TTI by comparing to VTI when dip is 0

RTM 6.7                                                                                                                                                        A2013 version

New Filtering Panel                                                  

Low Cut Filtering

This is an adaptive filter, designed to remove backscatter noise. For imaging without salt, a value of about 15 is typical. For imaging with salt, a higher value is necessary to get rid of more backscatter.

Zero would mean no filtering, and 30 is the maximum useable value.

 

Filter Gradient

When higher values for the Low cut filter are used, it is often useful to use the gradient. This changes the low cut filter as a function of depth, to allow more low frequencies into the image. Where factor is typically a number less than one. The factor is applied to the Low cut filter number, and ramped over the gradient. 


Example: 

Low cut 30:

3000    5000   .5

7000    9000   .333

 

In this case the filter value of 30 will be used down to a depth of 3000.

From 3000 - 5000 the filter is decreased by half to 15, so at 5000 is it 15

From 5000 to 7000 it stays at 15

From 7000 to 9000 it is decreased by  to 10

 

Salt Velocity and Salt Masking

The salt masking is useful for salt bodies and domes. It will allow more low frequencies within the salt, and at the salt boundaries and flanks. One should enter the velocity of the salt, and then select whether there is a dome or a salt body.

 

High frequency interpolation

Applying this new parameter will result in better recovery of higher frequencies. However, utilizing this feature will result in a 20% slower runtime.

 

Updated Performance Features                                                                            

Illumination Map  

The illumination scaling will now be applied internally and will not have to be manually applied after the migration. The illumination file will be saved which allows the user to still experiment with the scaling if desired.

 

1/t Scaling        

1/t scaling was modified to a floating point number that can accommodate positive and negative numbers.

 

Nodes per shot

This feature supports both CPUs and GPUs to correctly specify the number of shots per node.

 

Log Detail

The log detail feature has been expanded to provide more logging options. All log detail options will output a log file on the compute node’s /tmp directory.

                            

logdetail= 0; no log file will be created on any compute node

logdetail= 1; simple log file, does not print time step increments

logdetail= 2; detailed logfile, deleted after each shot. Warning: can create very large log files.

logdetail= 3; detailed logfile, not deleted after each shot. Warning: can create very large log files.

 

 

For instance if using logdetail= 3, a detailed logfile is created in the compute node’s /tmp directory. Each log file signifies a shot:

 

[user@computenode2 tmp]$ pwd
/tmp
[user@computenode2 tmp]$ ls -l Logfile*
-rwxrwxrwx 1 user avahi-autoipd 30275334 Oct 28 22:11 Logfile_server_node.02768
-rwxrwxrwx 1 user avahi-autoipd 30262326 Oct 28 22:15 Logfile_server_node.02793
-rwxrwxrwx 1 user avahi-autoipd 28498110 Oct 28 22:28 Logfile_server_node.02861
-rwxrwxrwx 1 user avahi-autoipd 28514988 Oct 28 22:33 Logfile_server_node.02883
-rwxrwxrwx 1 user avahi-autoipd 31424828 Oct 28 22:51 Logfile_server_node.02978
[user@computenode2 tmp]$

 

Fareen Elias August 15, 2012 Announcements

We are pleased to announce the release of Tsunami B2012.  This version of the Tsunami software contains new PSTM and PSDM modules as well as recent changes to the Tsunami GUI.  The latest versions include several new features to enhance performance as well as results.  

PSTM  & PSDM                                                                                                     

B2012 version pstm_6.2 and psdm_6.2

 

Better Port Connectivity

Previous versions of Tsunami would choose a starting communication port number at random, and then increment the port number for each compute node. If the port was in use, the job would fail. While this rarely happened, it could fail sometimes.

The current version checks for available port numbers before deciding which ones to use. This almost completely reduces the chances for a failure, due to ports being already in use.

 

CDP Numbers in the output file

Tsunami will retrieve the CDP numbers from byte 21 in the input data and place it output file. For every input trace with an input trace, it will copy the CDP number into a CDP map; if an input trace does not have a CDP number it will determine the inline and xline increments and extrapolate the CDP number. The only exception is when the xline numbers are also in byte 21, which will ignore the CDP numbering.

CDP numbering is usually based on some combination of the inline number, and number of xlines in the survey. If the number of xlines output from Tsunami is larger than the number of xlines in the survey, then the CDP numbers on the edge of the inlines may be duplicated, or meaningless.

 

Better communication between server and compute nodes

There is a recent change in the system command to expedite transfer of data from the server to the computer nodes. This is possible due to Tsunami no longer supporting SGI IRIX operating system, which allowed for clusters to contain nodes in both Big Endian and Little Endian format, slowing the transfer rate.

We now see network data transfers on GigE networks as high as 80 mbytes per second. This is approximately a 2x improvement.

 

Trace.db weights

The weights for the trace.db file were being recalculated for every job, sometimes unnecessarily. This has been changed so that weights are recalculated only when needed.

 

Fixed scaling weights problem

A bug has been fixed that scaled far offsets incorrectly, resulting in high amplitudes.

 

Fixed 1/t scaling bug

Previous versions of Tsunami required that the 1/t2 scaling power parameter (sphdiv) be an integer. Now any real number can be used.

 

GUI

Skip Initializing Output

Initializing of an output file ensures there is adequate space on disk to handle the output. However, with large jobs and large number of computer nodes, the initialization phase could add to the job’s run time. A checkbox has been added to skip initializing of an output file for both PSDM and PSTM.

In addition, this option will shorten run time by writing output traces directly to file. This implies there will be no check pointing of an offset group, as the output traces are not being written to file based on trace counts.

releasenotes.jpg

Fareen Elias March 29, 2012 Announcements

Release Notes for Tsunami A2012

Overview 

We are pleased to announce the release of Tsunami A2012.  This version of the Tsunami software contains new PSTM, PSDM, RAYS and SMTH modules as well as several Tsunami developed plugins for the INTViewer.  The latest versions include several new features to enhance performance as well as results.  

We would also like to take this opportunity to announce our updated website.  We hope that you find this website more clear, concise and ultimately easier to use.

PSTM                                                                                                  

A2012 version pstm_6.0

New Performance Feature

To keep the higher performance compute nodes busy, PSTM now caches seismic input traces on the compute nodes. By default it uses /tmp, however in the node list file you can specify another name for the scratch directory.

tm.newperffeat.jpg

The scratch directory needs to have at least 10 G of scratch space. The PSTM application will check that it can write to the scratch directory, and that there is at least 10 G of space.  If either of these tests fail, it will abort.  The logfile will list all nodes that fail this test.

When the job checkpoints, the compute nodes must sync up at that point so, they are all on the same trace. Some nodes may go idle while this happens.

In order for the user to know when the checkpoint will occur, the software will put the trace number for the checkpoints in the logfile at the beginning of the job.

New Merge Survey Weights Parameter

Tsunami allows the use of trace weights to minimize the acquisition foot print, and to make the amplitudes more consistent in the migration output.  These trace weights are stored in the trace database (trace.db).  This new parameter allows the use of trace scaling weights from previous trace databases, so the amplitudes will match when doing a survey merge. This allows you to merge surveys without having to re-migrate the combined datasets.

When the old trace database file parameter is detected, the program will look first for traces in this file, and use those weights, before calculating new weights for new traces not in this file.  The weight from the old trace.db, is then added to the current trace.db file, so the datasets can be cascaded forward. If additional data is then added to the dataset, the current trace.db file will then become the old trace.db file, and the weights can then be reused again. 

New fields were added to the trace.db for this new functionality.  Due to this, the previous version trace.db is not compatible with pstm_6.0 and vice versa.  The trace.db will be regenerated if the program detects a trace.db generated from another version.  

This parameter can be found on the Processing Tab under Amplitude Scaling.  The parameter name is oldtrcdb and its input is the direct path to the desired old trace.db file.  There is no default value.

tm.mergeweights.jpg

Floating Datum Enhancement

PSTM will now output the floating datum static in the same byte location as the static in the input data headers.  These will be placed in the output file regardless of outputting at final or floating datum.

Azimuth Update

The azimuth of the traces in the trace.db file have been changed to match the azimuth specified for HTI azimuth file, and for the TTI azimuth orientation.   The orientation is that 0 azimuth points parallel to the xlines, towards increasing inlines, and 90 azimuth points parallel to the inlines, towards increasing xlines.

Variable Velocity Fix

A bug fix was put in place to resolve a mismatch of headers in variable velocity migrations.

Balanced Offsets Fix

When using balanced offsets on very large datasets, the memory was not being released after the calculation of the offsets.  This caused the job to not have enough memory to start. 

Converted Wave Fix

The time/ frequency pairs will now be ignored when doing converted wave.  A bug caused an error message to be given in this situation.

 

 

PSDM                                                                                                           

A2012 version psdm_6.0

New Performance Feature

 

 To keep higher performance compute nodes busy, PSDM now caches travel times and seismic input traces on the compute nodes. By default it uses /tmp for the scratch directory, however in the node list file you can specify another path name for it to use.

dm.newpertfeat_yo.jpg

 The software will put a small amount of travel times on the compute nodes to start the job. It will then stream seismic traces and travel times to the compute nodes continuously while the job is processing.

 It is recommended that there is room on disk for approx 25% of the travel times. The software will print in the logfile what percentage of travel times will fit into memory, and what percent will fit on disk.

 Approximately 100-200 gig of disk can be used for this caching process.

 When the job checkpoints, the compute nodes must sync up at that point so, they are all on the same trace. Some nodes may go idle while this happens.

 The software will put the trace number for the checkpoints in the logfile at the beginning of the job, so the user knows when offsets will be output, or the job checkpointed. 

Floating Datum Enhancement

PSDM will now out put the floating datum static in the same byte location as the static in the input data headers.  These will be placed in the output file regardless of outputting at final or floating datum.

1/t Scaling Bug Fix

The 1/t scaling parameter (sphdiv) in psdm_5.8.sp1 was not behaving correctly. A positive number makes the
amplitudes decrease as a function of depth and a negative number increase as a function of depth. The parameter in psdm_5.8.sp1 was doing the opposite. The 1/t scaling has been fixed in psdm_6.0.  It is advised that before running any large job, you run a few small tests to ensure that you have the desired scaling.  Previously, the 1/t scaling parameter was limited to integer values.  It will now properly use floating point values.

2D  Crooked Line Fix

Using the 2D crooked line option will now ignore the delta x, y values when calculating the xline spacing.  It will just use the xline spacing parameter.

Memory Bug Fix

An issue regarding the limit on how much memory the master node can allocate was addressed, as well as a bug that caused problems when not keeping all offsets in memory.

 

 

RAYS                                                                                                             

A2012 version rays_5.10

Using Both Smoothed and Unsmoothed Velocity Models

 The raytracer now has the ability to use both smoothed and unsmoothed velocities for travel times generation.

 In Kirchhoff migrations, we have to smooth the velocity model to minimize the ray scattering when calculating the travel times. This smoothing is a rather subjective process, and the downside of it is inaccuracies in the velocity model. Smoothing the model changes the velocities, and changing the velocities causes changes in the image, and changes in the depth position of the events.

 With the new raytracer, we optionally allow the use of two models: a smooth one, which is used for calculating the ray paths, and an unsmoothed one, which is used to calculate the travel times. This increases the accuracy of the ray tracer, and allows events to be positioned more accurately.

 The benefits include:

  • Uses smooth velocities for calculating the ray paths to minimize ray scattering
  • Uses unsmoothed velocities for calculating the travel times, minimizing the velocity distortion from the smoothing
  • Minimizes the subjective nature of how much smoothing is enough, or too much
  • Images better under salt and around high velocity contrasts
rays.unsmth.jpg

The option to input the unsmoothed velocity model can be found on the files tab.  Parameter name is velunf and the value is the direct path to your desired unsmoothed segy velocity model.  The 2 velocity models may also be used in the smoother utility.  In this case, for the raytracer, you would specify the velocity block file created in the smoother as well as the 2 input velocity models. 

New Parameter

The visv0 parameter has been added to distinguish between V0 and Vvertical for TTI anisotropy.  This is found on the input tab.

 rays.newparam.jpg

 

SMTH                                                                                                             

A2012 version smth_5.9

2 Modes of Smoother

The smoother will now operate in two separate modes. 

Mode 1 outputs the smoothed version of the velocity and a block file that can be supplied to the ray tracer. The block file can be isotropic, anisotropic (both VTI and TTI) and can be a combination of both smoothed and unsmoothed velocities as required.

In Mode 2, the user inputs a single segy file, no block model is created and the output is a smoothed segy file.  The input is not limited to velocities but can be a segy file of eta values, deltav, etc.

smth.modes.jpg

The switch for smoother mode can be found at the top of the files tab.

Median Method of Smoothing

Median method of smoothing velocities has been introduced in the new release, which will remove anomalously high and low velocities. Median smoothing can be used in Mode 2 only.  Median smoothing is better for smoothing RMS, and non velocities. The average smoother is better for reducing the derivatives in interval velocity models. 

This parameter is found on the Options tab and is only active when Mode 2 has been selected.  The parameter name is avesm= 0. Default is to use the average smoother (avesm= 1).  The user will need to supply operator lengths for this method.  Calculate operator lengths is not available with the median smoothing method.

 smth.medianmethod.jpg

Using Both Smoothed and Unsmoothed Velocity Models

The raytracer now has the ability to use both smoothed and unsmoothed velocity models for travel time calculations.  If you are starting with an unsmoothed model, specify it as both the input velocity file and the unsmoothed velocity file in the smoother utility.  This will generate your smoothed output velocity model for use in the raytracer, as well as store the unsmoothed model information in the block model.  If using this method, you would then specify your new, smoothed velocity model, your original, unsmoothed velocity model and your block file from the smoother in your raytracer parameter file.

 

 

TOMO                                                                                                   

A2012 version tomo_5.8

New Trace.db Format

The Tomography program has been updated to use the new trace.db format.

 

 

GUI

Floating Datum Byte Size

A toggle has been added so that the byte location for the floating datum static may be defined as 2 byte or 4 byte.  Parameter name is dtmtyp.  Default is 4 smth.medianmethod.jpgbyte or dtmtyp= 0.  This parameter can be found in the Floating Datum section of the Input tab on both PSTM and PSDM.

Smoother Name Change

The Smooth Velocities option on the GUI start up window has been changed to Smooth Utility

Output Floating Datum Bug Fix

The GUI was previously outputting the output at floating datum option as outfltdatum when it should have used the name outfltdtm.  This has been corrected in the A2012 GUI.

Tomography Travel Time Bug Fix

The GUI would not allow a single file for the travel time and seed horizon files.  When a user tried to accept the parameters an error message would pop up. This is now working correctly.

 

INTViewer                                                                                                          

INTViewer 4.3

Tsunami Plug ins Released

Tsunami is pleased to release several of our in house designed plug ins for the INTViewer.  Plug ins released in this version are:

  • Plug in PWaveConversion. Users can generate a starting S-wave model with indexed P-wave and gamma files.
  • Plug in Load from ASCII.  Users can convert ASCII files containing laterally varying velocity or gamma files to SEGY.
  • Plug in VariableVelocityPicker.  Users can display gathers from variable velocity migrations and pick the velocities that best flatten the migrated events.
  • Plug in VariableVelocityAnanlysis. Users can create an updated velocity model using picks from the VariableVelocityPicker Plugin.
  • Plug in AutoPicker II.  Auto-pick horizons on gathers for input into Tomo.  Residual moveout on depth migrated.Plugin Floating Datum Correction.This plugin reads in a trace.db file and extracts the floating datum values. Once floating datum is known for each trace, it is applied. To save the new dataset, use the INTViewer menu item File->Save seismic datas
  • Plugin Horizon Depth Correction. Users can correct a horizon's depth values when the horizon is picked on a seismic dataset which has had specific interval velocities applied or when the horizon is in time and a depth conversion is desired.
  • Plugin Horizon Interpolation. This allows the user to input a horizon and select either 2D or 3D interpolation between the user picked points.
  • Plugin Horizon Polygon Edit.  Quality control tool for horizons. The input consists of 2 horizon files and a polygon file. The user defined polygon encloses a questionable area on a horizon.  Data points within the polygon are removed allowing the user to focus only on the questionable area for repicking.
  • Plugin  Horizon  Slice.  This plugin takes the seismic dataset and horizons in the currently selected window as input and uses this input to create a "flattened" region above and below each horizon. This slice data is then displayed in an INTViewer window. Once saved, indexed and transposed it can then be displayed in a Map window to view each horizon time slice.
  • Plugin Horizon Strike and Dip.  The plugin takes the input horizons and calculates the strike and dip values. These values are output to a separate strike file and dip file for display or use in other applications
  • Plugin Seismic Time to Depth Conversion. Convert a seismic dataset from time to depth or from depth to time using a user input velocity model.
  • Plugin Velocity Model Update. The user is able to delineate an area using either 1 (flood) or 2 horizons (top/bottom) per area and replacing the velocity within that area with a user defined velocity.
  • Plugin Velocity Resample.  The Velocity Resample plugin allows the user to input a 2D or 3D velocity model and change the increment of the Inline and/or Xline.
  • Plugin Velocity WellTop Updater.  The plugin creates a deltav mapping so the velocity for the seismic can be adjusted to the known horizon from the welltop
  • Plug in Angle Mute.   Apply an angle mute to seismic gathers, calculated by using the RMS velocity model.

All of the plug-ins have detailed help files that can be ac  cessed either through the Help->Help Contents on the menu bar or by clicking the Help button on the individual plugin's dialog box.

int.pluggins.jpg

Instructions for installing the new plug ins can be found here on our support portal.  Should you have questions about installing the plug ins or on any of our new features, please feel free to contact our friendly support staff at any time.

 

Jaclyn Cribley July 18, 2011 Announcements

Release Notes


Overview

I am pleased to announce our new release of Tsunami software, the Tsunami B2011 suite. This suite contains new versions of PSTM, PSDM, and Tomography. Details on the changes are contained herein.

 

I have been asked a few times now, what Tsunami is planning for upcoming releases. For our INTViewer customers, you will be pleased to know that we are planning our next release to contain new plug in tools developed for versions 4.0 and greater of the INTViewer. Our new Autopicker tool that has been under beta testing for some time and a semblance builder will be presented in the C2011 release. Additionally, we are planning the release of a new Rays and Smoother tool, though the date is not yet set. If you are not a current user of the INTViewer or you are just interested in what other tools are under development, please let your account representative know. They will be happy to show you more. sales@tsunamidevelopment.com

 

We are continuing to expand our support content for our customers. In May we added a support button to our homepage. Users can now submit a support request from any page on our website. This also means that our old support ticketing system is now defunct and has been removed from the site altogether.

image09.jpg

New support content is being added to our support portal every month at support.tsunamidevelopment.com. Some information is only available to customers, and those users will need to log in to see all the features it offers. If you forgot your password, no worries. You can request a reset link quickly and easily from the log in screen.

 

I want to take a moment to highlight two of the great benefits of the support portal for our customers. We are taking the more commonly asked questions and converting them into forum topics with detailed explanations and pictures, where possible, to make finding solutions fast and efficient. Users can interact with these support documents and let us know when more information is needed. It’s a great way to make support more powerful. Also, customer’s support request history is maintained and easily reviewed by the user or our support geophysicist. If a customer has an issue similar to something in the past the support representative can review this information to provide a timely solution. As we are supporting more companies around the globe, using the support portal or support@tsunamidevelopment.com means that we can deliver the excellent customer support you expect.

 

Before I sign off on this update, I also have to pass on news of our newsletter, lunch & learns, and the new support phone number. Starting in May Tsunami began sending out a monthly newsletter with information on new features, tools, and upcoming events. Speaking of events, we have begun hosting periodic Lunch N Learns in our Houston, Tx office. Look for these to start showing up in Europe late this year. If you are not getting the newsletter or you want to know about upcoming events before they happen, email Melanie Blind melanie.blind@tsunamidevelopment.com. Finally, Tsunami Support has a new direct number! +1 713-900-2099 will call our support staff directly, no fancy queues or numbers to press. If we are there, we will answer the phone, but if we are not please leave us a voicemail. It will be emailed to entire group, and someone can get back to you quickly.

 

Happy migrating,

 

image07.gif

 

Jaclyn Cribley

Operations Director

Tsunami Development

 

 


 

General

In the latest release users will see a change to the structure of the INTViewer installers. Inside the release will be a directory named INTViewer and under that a directory called releases which will contain multiple version of the latest INTViewer as well as supporting files. Users may install which ever version of the viewer they wish. Newer versions will support more plug ins as they are released. The viewer will only work for Tsunami customers with a current license. Please contact your sales representative if you have questions.

 

image08.png

PSTM new features

 

The newest release of Pre-Stack Migration software is PSTM 5.9.

Data Preparation

 

In the previous release of the Tsunami Suite, A2011, we released the data preparation features in our depth migration software. This release of Tsunami B2011 brings these same features to our Pre-Stack Time Migration. These processes are applied before the migration.

•Amplitude Scaling computes and applies a time variant scaling function defined by a 1/t scaling power. For example, enter a parameter value of 2 to scale the input trace by 1/t2.
•Filters applies a Bandpass frequency filter defined by low cut/high cut frequency pairs. Enter values for zero pass frequency and full pass frequency to define the high cut and low cut ramps.
•AGC automatically applies an AGC operator length defined by the Window Length parameter.

Converted Wave algorithm changes

Many changes were made to our algorithm for converted wave applications to improve the image quality. Most of these changes involve improvements to the underlying algorithms and will be transparent to the user. New variable velocity options allow variation of gamma and of both P-wave and S-wave velocities together. Previous versions used a single gamma function. The new release allows use of a spatially varying gamma field. We feel that the updates give an image of superior quality to the results produced by other tools on the same data.

 

Input data in PP and PS time is now supported and can be selected on the user interface.

 

A new utility has been added in the INTViewer to generate an S-wave model from a P-wave model and a gamma file. SEGY models can be generated from ASCII input files. This utility will work with gamma, velocity and eta data and is implemented in the INTViewer. plug in names

 

For information on installing INTViewer plug-ins refer to the support article built into the INTViewer help.

PSTM Enhancements

1/t **n changes

In previous versions the user could only supply positive integers for this variable. The program will now accept negative and positive integers.

PSDM Enhancements

The latest release of PSDM is 5.8.sp1.

Output at Floating Datum

This option, when selected was not properly outputting data as expected. This has been corrected.

 

TOMO Enhancements

The latest release of PSDM is 5.7.sp1.

Error: Negative Slowness

Users reported receiving the error “Negative Slowness” in the log file. This error was the result of a miscalculation which has been corrected.


GUI new features

Data Prep Tab

The data prep tab was added to support the new features of PSTM discussed earlier.

image00.jpg

Geometry tab now has Check Coordinates

Traditionally PP data  causes the data to fail the geometry check. There is an option on this tab to skip the geometry check, which will prove useful when you working with the converted wave application. 

Converted Wave Tab

The Converted Wave Tab now has Domain of Input Seismic, choices are PP or PS, and  the VP/VS (Gamma) Velocity Model user option.

image01.jpg

Variable velocity tab

The Variable Velocity tab now has  a new Function option of Gamma (VP/VS) and a Function option of P-Wave & S-Wave velocities.

image02.jpg

Changes to GUI

Internationalization bug

When the OS has been set to a language that uses commas rather than periods in representing a floating point number, numerous problems occur in setting parameters, both in the user interface and the INTViewer.  The Tsunami start up script has been modified to resolve this issue.

Geometry Map / trace.db

When the trace.db file is read, any shots or receivers falling outside the defined INLINE / XLINE boundary were assigned a shot number of zero. If  a shot zero was detected, the geometry map failed with the error, “XXX.” This has been corrected.

image04.png

Data Prep tab

1/t scaling has been moved from the Processing tab and is now a user supplied value as described above.


Known Issues

Updates for known issues are maintained on our support portal at support.tsunamidevelopment.com. This is a list of known at this time.

TOMO Travel Time Files

 

image03.jpg

The GUI says it will take a single file for the travel time and seed horizon files.  However, the user interface is only accepting a list of files. The work around is to supply a file list for the travel times.

Output at floating datum in PSTM

image05.jpg

image06.jpg

In the user interface on the Output tab, there is a parameter to output at the floating datum. At this time this feature works in PSDM but is not functional in PSTM. A solution is under development for the next release of PSTM, and if any user desires a beta version in advance, please contact Tsunami at support@tsunamidevelopment.com. 

Jaclyn Cribley March 30, 2011 Announcements

A2011 Release Notes

Tsunami_release-1.gif  

Dear Tsunami Customer:

We thank you for your continued use of our software and support in making the Tsunami Suite better. Special thanks go out to our customers who have worked with us to add the most wanted features. Feedback and requests from our users are what drive our continued improvement.

This release contains enhancements to Pre-Stack Depth Migration and Ray Tracer. We have long supported VTI anisotropy; and now the Tsunami suite allows you to use TTI in ray calculation. The Pre-Stack Depth Migration application can directly prepare data for migration.

To get updates on planned changes and releases of our software, please visit our new support portal for the latest information ( http://support.tsunamidevelopment.com/ ). Do not hesitate to call us, or email our customer support team any time at support@tsunamidevelopment.com .

Sincerely,

Tsunami_release-3.gif

Jaclyn Cribley

Operation Director

 

 

The Information contained in this document is subject to change without notice. Tsunami Development assumes no responsibility for any error that may appear in this manual. Tsunami Development does not warrant that this document is error free. Please report any errors in this document in writing to Tsunami Development. Some states or jurisdictions do not allow disclaimer of expressed or implied warranties in certain transactions; therefore this statement may not apply.

Tsunami_release-4.gif
Overview
Tsunami_release-4.gif

The A2011 Tsunami Suite releases an enhanced Pre-Stack Depth Migration 5.8. We now include a Data Prep tab which allows you to prepare your data for migration directly in PSDM. With this release you can now scale and filter trace data before running migration; this feature will also be added to Pre-Stack Time Migration in the next release. An enhanced Ray Tracer 5.8 is also included in this release which allows tilted transverse isotropy (TTI) to be incorporated in the calculation of the travel times.

We have made fixes to Ray Tracer, Smooth Velocity 5.7, and Pre-Stack Time Migration 5.8. Pre-Stack Depth Migration’s Geometry Map now allows for display of very large datasets.

We also updated how the GUI stores user profile information for recently viewed parameter files and the last opened directory.

There are no known problems at this time.

Tsunami_release-4.gif
New Features

Pre-Stack Depth Migration 5.8

Tsunami releases Data Prep in Pre-Stack Depth Migration 5.8 so our clients can prepare their data for migrations directly in PSDM. With this release you can now scale and filter trace data before migration.

Data prep

Select Pre-Stack Depth Migration > Data Prep to apply the following parameters:

•Amplitude Scaling computes and applies a time variant scaling function defined by a 1/t scaling power. For example, enter a parameter value of 2 to scale the input trace by Tsunami_release-5.gif

•Filters applies a Bandpass frequency filter defined by low cut/high cut frequency pairs. Enter values for zero pass frequency and full pass frequency to define the high cut and low cut ramps.

•AGC automatically applies an AGC operator length defined by the Window Length parameter.

 

Tsunami_release-6.gif
Ray Tracer 5.8

TTI anisotropy can now be incorporated in the calculation of the travel times in Ray Tracer by supplying azimuth and dip files to the input parameters.

Support for TTI

The observed phenomenon of waves traveling at different speeds through the earth, depending on their direction of propagation, is known as Seismic Anisotropy. This effect can be caused by geological factors such as layering, fracturing, tilting, etc. When layers are relatively flat and the principal cause of anisotropy is fine layering, such as that commonly found in shales, the medium is said to be Vertically Transversely Isotropic, or VTI. In this case, the wave travel times vary between the purely vertical and purely horizontal directions. The anisotropic parameters epsilon and delta describe this relationship between horizontal and vertical velocities, and are used as additional input to the imaging software. This assumption works well for imaging in many settings.

When structural deformation has occurred, and the anisotropic layers are no longer horizontal, other factors must be included in order to perform accurate imaging. These cases are known as Tilted Transverse Isotropy, or TTI. In addition to the anisotropic parameters epsilon and delta, dip and azimuth information must also be input to the imaging software in order to describe the structure. This can become particularly important in structurally complex areas such as overthrust zones. If TTI imaging is not performed in areas such as this, vertical and/or lateral mispositioning of events may occur.

The following files are all required for TTI:

Epsilon file:

Provide an epsilon SEG-Y file. The file must contain epsilon values at the same inline, xline and depth as the velocity samples in the velocity model.

Example: /projects/summit/epsilon.sgy

Default: None

Status: Required for TTI.

Delta File:

Provide a delta SEG-Y file. The file must contain delta values at the same inline, xline and depth as the velocity samples in the velocity model.

Example: /projects/summit /delta.sgy

Default: None

Status: Required for TTI.

Azimuth File:

Provide an azimuth SEG-Y file. The file must contain azimuth values at the same inline, xline and depth as the velocity samples in the velocity model.

Example: /projects/summit /azmiths.sgy

Default: None

Status: Required for TTI.

Dip File:

Provide a dip SEG-Y file. The file must contain delta values at the same inline, xline and depth as the velocity samples in the velocity model.

Example: /projects/summit /dip.sgy

Default: None

Status: Required for TTI.

 

Tsunami_release-7.gif

Tsunami_release-4.gif
Fixes and/or Changes
Tsunami_release-4.gif

General

Recently viewed parameter files and the last opened directory information are stored in a hidden .tsunami file. The application previously wrote the .tsunami file to the directory from which the GUI was launched. When another user launched the GUI from the same directory, errors occurred because preferences from the previous user were used for the second user if permissions for the .tsunami file were closed. The .tsunami file is now stored in each user’s home directory to avoid these problems.

Pre-Stack Depth Migration 5.8
Geometry Map

When working with extremely large data volumes, building extended trace databases failed. This has been fixed and tested on a 186 million trace data volume. In practice, processor speed and system memory determine how usable the tool is with extremely large volumes.

 

Tsunami_release-8.gif
Pre-Stack Time Migration 5.8
Incorrect log file messages

Clients reported that PSTM would not read GCI data and received a log file report error #51:

WARNING: CDP X,Y byte locations not specified
Outputting CDP X byte 213 CDPY byte 217
Opening trace input file /hds21/gci/BeauregardPa_SW.PSDM1.gathinp2.GCId.1
ERROR #51: Invalid number of samples read from trace header
check byte location
Remove tmp file
Job aborting, got signal -1
Job aborting, got signal -1
Error code 0

The problem was that CDPX and CDPY were put in bytes 209 and 213 when an input byte location was not specified. Byte 209 is the default for the Migration distance. This is now fixed and CDPX and CDPY are in bytes 213 and 217 whenever an input byte location is not specified.

Anisotropy

The ETA file selection option in Pre-Stack Time Migration > Processing was greyed out and some clients were unable to work with anisotropy. This has been fixed.

 

Tsunami_release-9.gif
Ray Tracer 5.8

When epsilon/delta models with velocities were used for vertical transversely isotropic (VTI) media, Ray Tracer printed the value of the velocity derivatives incorrectly. This has been fixed.

Smooth Velocity 5.7

When epsilon/delta values were less than zero, Smooth Velocity would display the negative values as zero when printing the values’ range of the model. Also, the application was reporting the wrong velocity derivatives when Epsilon and Delta were present. This has been fixed.